Surface Pro 回復ドライブの作成

Posted in ハードウェア, モバイル関連 on 6月 7th, 2013 by Site Administrator

Surface Pro、本日発売でした。

早速購入し、いろいろ遊んでいます。
遊ぶ前にリカバリディスクの作成、といきたいところですが、このPCでは
「回復ドライブの作成」ということで、USBディスクを使ってのブートメディアの作成になります。

必要なUSBメモリの容量は8GB。8GBの新品ディスクが手元にあったのですが、事前に調べると
8GBで足りないという情報が。16GBも買ってきてみたのですが無駄になりました。。。

大事なことなので2回言います。8GBで足りました!

LSI 9265-8i CacheCadeでのSSD使用状況

Posted in ハードウェア on 5月 22nd, 2013 by Site Administrator

LSIの9265-8iで、しばらくCacheCade運用してました。

PlextorのPX-256M3を1台で、Readキャッシュとしての使用でした。

CrystalDiskInfo 5.6.2
—————————————————————————-
Model : PLEXTOR PX-256M3
Firmware : 1.05
Disk Size : 256.0 GB (8.4/137.4/256.0/—-)
Buffer Size : 不明
Queue Depth : 32
# of Sectors : 500118192
Rotation Rate : —- (SSD)
Interface : Serial ATA
Major Version : ATA8-ACS
Minor Version : ATA/ATAPI-7 T13 1532D version 4a
Transfer Mode : SATA/600
Power On Hours : 2938 時間
Power On Count : 65 回
NAND Writes : 160879 GB
Temparature : 不明
Health Status : 正常 (100 %)
Features : S.M.A.R.T., 48bit LBA, NCQ, TRIM
APM Level : —-
AAM Level : —-

— S.M.A.R.T. ————————————————————–
ID Cur Wor Thr RawValues(6) Attribute Name
01 100 100 _70 000000000000 リードエラーレート
05 100 100 __0 000000000000 代替処理済のセクタ数
09 100 100 __0 000000000B7A 使用時間
0C 100 100 __0 000000000041 電源投入回数
B1 100 100 __0 00000013A37F ウェアレベリング回数
B2 100 100 __0 000000000000 使用済予備ブロック数 (ワーストケース)
B5 100 100 __0 000000000000 書き込み失敗回数 (トータル)
B6 100 100 __0 000000000000 消去失敗回数 (トータル)
BB 100 100 __0 000000000000 訂正不可能エラー数
C0 100 100 __0 00000000002F アンセーフシャットダウン回数
C4 100 100 __0 000000000000 セクタ代替処理発生回数
C6 100 100 __0 000000000000 回復不可能セクタ数
C7 100 100 __0 000000000003 CRC エラー数
E8 100 100 _10 000000000000 利用可能な予備領域 [寿命]

SOHOサーバで、24時間運用。用途はファイルサーバと、開発環境用HYPER-Vホストです。
参考までに。

CakePHP 2.3.3 →以前のバージョンはとてつもなく危険。すぐアップデートすべき。

Posted in CakePHP, PHP関連 on 4月 26th, 2013 by Site Administrator

CakePHP2.3.3が先日リリースされましたが、これ以前のバージョンを使用している方は即適用すべきです。
適用できないなら即対応策を考えるべきです。

具体的なコードはあえて書きませんが、非常に簡単な手順で認証が突破されてしまいます。

「From認証を使用し、かつSecurityComponentを利用していない環境で発生する」とアナウンスされてますが、
SecurityComponentを使っていても発生しました。

2.2.x以前でも発生するかはまだ確かめてません。

対応策はこんなところでしょうか
1.カスタム認証ロジックを組み込む または
2.2.3.3にアップデート

急ぎましょう。本当に危険!

<追記 2013/04/26 15:21>
Version2.2.7で、同様の方法では認証が突破されないことを確認しました。
2.3系だけの問題のようです。

Dune HD TV-303D

Posted in ハードウェア on 4月 24th, 2013 by Site Administrator

PC内の各種メディアファイルをTVにて再生するために購入しました。

まだセットアップ中なのですが、気になった点が。

・無線LANの設定で、ステルスSSIDの設定がされている環境では接続できない
・共有フォルダ内のファイルを再生する場合、フォルダに認証設定がされているとアクセスできない

どうにか解決したいところです。

CakePHP 2.2.2 SessionをDBに格納する場合のPHPUnitエラー

Posted in CakePHP on 9月 28th, 2012 by Site Administrator

MissingTableException
Table cake_sessions for model Session was not found in datasource test.

「cake_sessions」テーブルを、testデータベースに作成すると回避できる

さくら 専用サーバ エクスプレス OSインストール

Posted in OS関連, ハードウェア, 開発関連 on 9月 26th, 2012 by Site Administrator

どうにかこうにかしながら、Windows OS を独自でインストールすることに成功しました。

・Windows 2012 Server

→内部ネットワーク接続のHYPER-VマシンにRRASでNAT設定をして外部からRDP接続しようと試みるが、

パフォーマンスが非常に悪い。ホスト上からのRDP接続だと問題ないのに。

あとホスト再起動時の保存・復元処理もパフォーマンスが悪い。相変わらずのことながら初物なので不安定?

 

・Windows 2008 Server R2

→というわけで、安定しているこのOSをインストールしてみます。

さくら 専用サーバ エクスプレス アレイ切り分け

Posted in ハードウェア, 開発関連 on 9月 22nd, 2012 by Site Administrator

さくら専用サーバ エクスプレスでは、P410 にディスクが2本ぶらさがり、

初期状態では容量いっぱいにRAID1が1ドライブ定義されています。

どうにかしてこの1ドライブを分割したかったのですが、RAIDボードのBIOSからは

サイズ指定のドライブ定義が不可。hpacucliを使っても、hpacucliインストールされている

ドライブは削除不可能とか、いろいろ試したけれどもうまくいきません。

唯一、XenServer6をインストールした場合のみ、hpacucliを使ってインストールされている

ドライブも削除できます。削除後、サイズ指定でドライブ作成、と。

 

なにかの役に立つかわからないですけど、何かのために残しておきます。

AzureでBitNami Redmine 2.0.3 安定稼働のために

Posted in Azure, 開発関連 on 7月 25th, 2012 by Site Administrator

 

結局改善しませんでした。Windows7(32bit)では安定稼動しているので、

素直に別なOSを考慮したほうがいいかもしれません。

 

 

Windows Azure でVM運用が可能になったので、AzureのWindows 2008R2 Extra Small
インスタンスにBitNami Redmine2.0.3を入れて運用しています。が、気が付くとインスタンスが落ちている、ということが多すぎる…。
とっても不安定で、都度リモートでVMの再起動を行っています。
次の設定変更を行ってからは安定して稼働しています。様子見です。
・Rubyプロセスが2本立ち上がっているのを1本にする(サービスを自動起動しないようにする)。
・ロードバランサで1本のみ見に行くように変更する。
・一応定期的にサービスの再起動(数時間毎)

Azure CentOS rootパスワード変更

Posted in Azure, OS関連 on 6月 17th, 2012 by Site Administrator

さっそくAzureのIaaS機能を試してます。

CentOS環境を作成し、rootのパスワードを変更しようとすると

「Authentication token manipulation error」

というエラーが。

pwunconv

pwconv

とコマンドをたたいて、再度passwdで変更可能になりました。

 

Authentication token manipulation error

vyatta 6.4 インストールメモ

Posted in OS関連, 開発関連 on 5月 30th, 2012 by Site Administrator

Vyatta6.4でとりあえずルーターとしてセットアップするメモ。

nat設定とか、インストールのコマンドが6.4から変更になってます。

1.インストール
install system
reboot

2.システム情報設定
configure
set system host-name vyatta
set system domain-name domainname.com
commit
save

3.WAN側基本設定
configure
set interfaces ethernet eth0 address 192.168.222.2/24
set system name-server 192.168.222.1
set system gateway-address 192.168.222.1
commit
save
※DHCPで取得するならaddressに dhcpを設定。PPPoEなんかもこんな感じで設定。

4.LAN側基本設定
configure
set interfaces ethernet eth1 address 192.168.10.1/24
commit
save

5.LAN側DHCP設定
configure
set service dhcp-server shared-network-name ETH1_POOL subnet 192.168.10.0/24 start 192.168.10.50 stop 192.168.10.100
set service dhcp-server shared-network-name ETH1_POOL subnet 192.168.10.0/24 default-router 192.168.10.1
set service dhcp-server shared-network-name ETH1_POOL subnet 192.168.10.0/24 dns-server 192.168.10.1
set service dns forwarding listen-on eth1
set service dns forwarding system
commit
save

6.LAN側NAT設定
configure
set nat source rule 1 source address 192.168.10.0/24
set nat source rule 1 outbound-interface eth0
set nat source rule 1 translation address masquerade
commit
save